Oldskooler 1.4.0 Released!


This is just a long overdue compatibility update to Unreal Engine 4.17. The giant overhaul that is Oldskooler 2.0 is coming next!

Get Oldskooler

Buy Now$19.99 USD or more

Leave a comment

Log in with your itch.io account to leave a comment.